<<

Arduino UNOを使用する

Arduinoの環境設定をインストールし、スケッチを書き込み、LEDを点灯させるまでの手順です。

必要なもの

  • Arduino UNO(参考)
  • A-BタイプのUSBケーブル(Arduino UNOには付属していないので注意)
  • φ3mmLED(赤)(参考)
  • 抵抗(240Ωくらい)
  • ブレッドボード(大きめのを1枚、小さめのを)
  • ジャンパーワイヤー(オス-オスなど数本)
  • (必要であれば)Arduino用ケース(参考)
  • PC(Windows/Mac OS X/Linux)

Arduino UNOは現在SMD版(参考)というバージョンも販売されています。Arduino UNOとの違いはメインのICが外せる(ATmega328P-PU)か外せない(ATmega328P-AU)かの違いしかありません(性能はまったく同じ)。Arduinoにどっぷり浸かる予定がなければどちらを買っても問題ありません。ただ、メインのICだけ(器用に)壊れたときは外せる方を選んでおくと数百円の出費で治せたりします。またメインのICを外して単体で運用するといったマニアックな使い方をする予定があればこちらも外せる方を選択しておくと幸せになれると思います:P

抵抗値を正確に出したい人は「ここ」とか「ここ」とか「ここ」などを参考にするといいです。

ジャンパーワイヤー(ジャンプワイヤ)は余裕があれば10cmと20cmを10~20本、針金タイプ(参考)を1セット、「オス-ワニグチ」を10本程度揃えておくとワイヤ不足で泣く確率が減ると思います。

PCはWindows、Mac OS X、Linux(32/64bit)が使用可能ですが、自分はWindows 7(64bit)を使用しています。

手順

手順は以下のとおりです。

  1. Arduino IDE(統合開発環境)をインストール
  2. 回路を構成する
  3. スケッチを書く
  4. Arduino UNOとPCを接続してスケッチを書き込む

Arduino IDE(統合開発環境)をインストール

スケッチ(Arduinoのプログラム)のコンパイルと、Arduinoへのスケッチの書き込みを行うためのソフトウェア「Arduino IDE」をインストールします。

ダウンロードはArduinoの公式ページの「Download」からできます。2011/07/18現在、バージョンは「0022」です。なお年数回アップデートされているので時々確認したほうが良いです。

インストーラーは無く、ダウンロードしたZIPファイルを解凍したらそのまま使用できますので適当なフォルダに展開して置きます。なお、海外製のソフトウェアなのでデスクトップや日本語名のフォルダ(ファイルも)などは避けたほうが無難です(たぶん大丈夫ですがなんとなく気分的に…)。

回路を構成する

図のようにArduino UNOにLEDと抵抗を接続します。

TestBlink.PNG
TestBlink.JPG

Arduino UNOに外部電源用のコネクタ(φ2.1mm)が付属していますが、USBから給電できるので接続不要です。もし、単体動作する場合は別途7~12Vの電源が必要になります。

スケッチのアップロード後であれば、外部電源のみで駆動可能です。

USBと外部電源の両方が接続されている場合は外部電源から電源を取得します。

スケッチを書く

最初にダウンロードしたArduino IDEのフォルダから「arduino.exe」を実行します。

起動したらテキストエディター部に以下のスケッチを記述します。

int LED1 = 13;

//起動直後に1回だけ実行される関数
//※リセット後もここから実行される
void setup()
{
  pinMode(LED1, OUTPUT);     //指定したピンを出力モードにする
  digitalWrite(LED1, HIGH);  //指定したピンをHIGHに設定する
}

//setup()が実行された直後に繰り返し実行される関数
void loop()
{
}


スケッチの初回保存時はスケッチを保存したい場所とスケッチの名前を指定します。するとスケッチ名のフォルダ(スケッチブック)を自動的に作成し、その中にスケッチを保存します。スケッチを保存するデフォルトの場所は「File->Preferences->Sketchbook location」で指定できます。

記述したら「Verify」(GUIからVerifyボタンを選択するか、「Sketch->Verify/Compile」か、「Ctrl+R」)を実行します。

内容に問題がなければ「Binary sketch size: xxx bytes (of a xxxxx byte maximum)」というメッセージが1行だけ表示されます。何か問題があれば赤いエラーメッセージが表示されます。

setup関数とloop関数は最低限必要な関数になります。これらが無いとコンパイルエラーになります。

ちなみに上記のHTMLタグ付きフォーマットはArduino IDEの「Edit->Copy as HTML」で生成可能です。

あと「Shiftキーを押下しながらVerifyボタンを押下する」とコンパイルの経過がメッセージに表示されるようになります。

Arduino UNOとPCを接続してスケッチを書き込む

Arduino UNOとPCの初回接続時には以下を確認します。

  1. Arduino UNOとPCをを接続します。初回接続時にはドライバのインストールが必要になりますが、vista以降では自動的にインストールされます。それ以前のXPではArduino IDEの「drivers」フォルダからインストールする必要があります。
  2. 「Tools->Board」から「Arduino UNO」を選択します。
  3. 「Tools->Serial Port」で「Arduino UNO」の接続ポート番号を選択します。

以上の設定が完了したらArduino IDEから「Upload」(GUIからUploadボタンを選択するか、「File->Upload to I/O board」か、「Ctrl+U」)を実行するとArduino UNOにスケッチがアップロードされます。正常にアップロードすると「Done uploading」というメッセージが表示されます。

アップロードが完了するとスケッチが自動的に実行されます。

なおArduino UNOの本体上に付属しているボタンはリセットボタンで、押下するとスケッチ内容が最初から実行されます。スケッチのアップロード後に自動的に実行されないケースがあるらしく、この場合はリセットボタンを押下するとスケッチ内容が実行されます。

サンプルコードを試す

Arduino IDEにはいくつかサンプルコードが用意されています。「File->Examples」からそれらをロードすることが可能です。

上記の回路であれば「Basics->Blink」を実行すると「1秒おきにLEDが点灯と消灯を繰り返すサンプル」が実行できます。

参考


添付ファイル: fileTestBlink.PNG 1223件 [詳細] fileTestBlink.JPG 2698件 [詳細]

トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS   最終更新のRSS
Last-modified: 2014-02-16 (日) 09:58:56 (1165d)